MacbookをMojaveにアップデートしたらbundle installでこける

問題

MacbookをMojave 10.14にアップデートしたらbundle installでこける

(略)
An error occurred while installing ffi (1.9.25), and Bundler cannot continue.
Make sure that `gem install ffi -v '1.9.25' --source 'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
  selenium-webdriver was resolved to 3.14.0, which depends on
    childprocess was resolved to 0.9.0, which depends on
      ffi

f:id:fujitora:20190102225244p:plain

解決方法

  1. xcodeをアップデート App Storeからxcodeをアップデート

  2. コマンドラインツールをインストール

$ sudo xcode-select --reset

今まで入ってたはずなのに

  1. パッケージのインストール
$ open /Library/Developer/CommandLineTools/Packages

でFinderにインストール用のパッケージがあるのでダブルクリックでインストール

参考サイト

qiita.com

qiita.com

macOS を Mojave にあげた後に Homebrew を使うとエラーが出る問題 | gotohayato